View Issue Details

IDProjectCategoryView StatusLast Update
00292611.4 IDE BugsBuild iOSPublic2018-08-13 12:05
ReporterStewart BishopAssigned ToChris Harrison 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformiOSOSmacOSOS Version
Product Version1.4.1804 
Target Version1.4 FinalFixed in Version1.4 Final 
Summary0029261: Build iOS: Unable to create an executable as we look for xcuserdata rather than xc*data
DescriptionWe previously made this fix for GMS2 but seems like we've forgot to make this change for GMS1, if you attempt to build an executable using Xcode 9.3 on the latest stable then this will not work at all as we look for a fixed string rather than the wildcard. If I run the command in command prompt replacing xcuserdata to xc*data then I'll be able to build an archive as expected.

Unsure if this affects running at all as I've not seen any issues with this personally but we have users reporting that nothing works on iOS for them currently.
Steps To Reproduce1) Run the attached project on iOS
2) It should work and just show a grey screen
3) Create executable
4) It should stall trying to open the project as it's looking for xcuserdata rather than xc*data
5) Run the same command in command prompt replacing the xcuserdata with xc*data and see that this works
Tags1_4_final
1.4 Found In1.4.1804

Activities

Dan

2018-08-13 12:05

Adminstrator   ~0061193

Have been able to build projects on multiple Macs since this fix. Closing.