View Issue Details

IDProjectCategoryView StatusLast Update
00288391.4 IDE BugsBuild MacPublic2018-09-02 16:56
ReporterStewart BishopAssigned ToSteven Campbell 
PriorityLowSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformOSWindows 10OS Version
Product Version1.4.1804 
Target Version1.4 FinalFixed in Version1.4 Final 
Summary0028839: Build Mac: Putty doesn't quote your password or escape the string so your password fails if it starts with a symbol
DescriptionWhilst verifying another bug I made my Mac password !"£$%^&*() at which point when you attempt to build or test a connection to the Mac you'll get this error:

cmd /c ""C:\Users\stewart.bishop\AppData\Roaming\GameMaker-Studio\putty\plink" -ssh -batch -pw !"£$%^&*() Stewart@10.36.11.76 echo Hello World"

PuTTY Link: command-line connection utility
Release 0.62
Usage: plink [options] [user@]host [command]
       ("host" can also be a PuTTY saved session name)
Options:
  -V print version information and exit
  -pgpfp print PGP key fingerprints and exit
  -v show verbose messages
  -load sessname Load settings from saved session
  -ssh -telnet -rlogin -raw -serial
            force use of a particular protocol
  -P port connect to specified port
  -l user connect with specified username
  -batch disable all interactive prompts
The following options only apply to SSH connections:
  -pw passw login with specified password
  -D [listen-IP:]listen-port
            Dynamic SOCKS-based port forwarding
  -L [listen-IP:]listen-port:host:port
            Forward local port to remote address
  -R [listen-IP:]listen-port:host:port
            Forward remote port to local address
  -X -x enable / disable X11 forwarding
  -A -a enable / disable agent forwarding
  -t -T enable / disable pty allocation
  -1 -2 force use of particular protocol version
  -4 -6 force use of IPv4 or IPv6
  -C enable compression
  -i key private key file for authentication
  -noagent disable use of Pageant
  -agent enable use of Pageant
  -m file read remote command(s) from file
  -s remote command is an SSH subsystem (SSH-2 only)
  -N don't start a shell/command (SSH-2 only)
  -nc host:port
            open tunnel in place of session (SSH-2 only)
  -sercfg configuration-string (e.g. 19200,8,n,1,X)
            Specify the serial configuration (serial only)
Steps To Reproduce1) Change your password on your Mac to !"£$%^&*()
2) Update your preferences to your new password
3) Within preferences check mac connection
4) See that this fails
5) Run on Mac
6) See that this also fails
Tags1_4_final
1.4 Found In1.4.1784

Activities

Steven Campbell

2018-02-12 09:45

Developer   ~0057676

From playing with this, it looks like the character escaping between CMD and BASH fighting each other... I'm not entirely sure we can actually fix this in a way that supports all those characters.
Will keep poking at it...

Steven Campbell

2018-02-13 17:29

Developer   ~0057714

Fixed in GitLab Git Id: 688817bc1eaa5b94958e7c2604c0f032a5f66a8b

Dan

2018-07-02 10:33

Adminstrator   ~0060770

Ubuntu gets the same fix.

Dan

2018-09-02 16:56

Adminstrator   ~0061424

Fine in 1.4.9999. Closing.