View Issue Details

IDProjectCategoryView StatusLast Update
0028627RunnerHTML5Public2018-06-27 12:19
ReporterStewart BishopAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target VersionFixed in Version2.1.3 
Summary0028627: HTML5: Keyword "undefined" works by a total fluke
DescriptionWhen you type the following in GameMaker Studio 2:
var a = undefined;
and then compile in HTML5 (debug mode), this produces this output:
var gmla = g_pBuiltIn.undefined;

This works by a total fluke, because g_pBuiltIn is an object and properties that are not defined in JavaScript returns undefined (and g_pBuiltIn.undefined is not defined anywhere in the runtime).

This should be fixed, so it compiles with this JavaScript output:
var gmla = undefined;
Steps To Reproduce1) Run the attached project in debug mode
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.3.189
2.x Runtime Verified In2.1.3.189

Activities

Stewart Bishop

2018-01-05 11:47

Adminstrator  

undefined_bug.yyz (12,868 bytes)

Russell Kay

2018-01-11 22:00

Manager   ~0057295

Fixed in gitlab - awaiting merge - this was intentional as it is the way it is implemented on C++ but I agree we should change it so I fixed it as outlined.