View Issue Details

IDProjectCategoryView StatusLast Update
0028344RunnerUbuntuPublic2019-02-13 13:04
ReporterStewart BishopAssigned ToAlan Savage 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target VersionFixed in Version 
Summary0028344: Ubuntu: File paths for Steam Workshop items appear to not be whitelisted or a part of the file sandbox
DescriptionGMS appears to refuse to acknowledge the existence of Workshop files on Ubuntu, for example when using file_exists() it always returns false. I can confirm this is a bug because GMS itself reports the correct Workshop file paths for me in the compile window which appears on the Ubuntu device.

The exact code I have works fine on Windows and MacOSX. I tried flipping the backslashes and inserting the full file path of a Workshop item as a string, and still no go.

file_exists() DOES return true on Ubuntu for files WITHIN the file sandbox. It just doesn't acknowledge any files outside of the sandbox. If I had to guess, I'd say the Steam Workshop file paths aren't being properly whitelisted for reading/sandbox use.
Steps To Reproduce1. Start Steam, download my Steam game TUNNEL DIVERS (linux version should just be an empty game)
2. Subscribe to this Workshop item:
3. Wait for the item download to finish
3. Run the attached project with Steam still open (It will run under my game's app ID)
4. Press F2 to check for the external workshop file's existence
5. Green line confirming file's existence should appear
6. Repeat exact process for the Linux export, bug causes file_exists() to return false instead.
TagsNo tags attached.
1.4 Found In1.4.1772
2.x Runtime Found In2.1.2.172
2.x Runtime Verified In



2019-02-13 13:04

Adminstrator   ~0062781

Mass-closing some super-old resolves. Will add them as new issues with fresh info if they are reported again.