View Issue Details

IDProjectCategoryView StatusLast Update
0028089RunnerHTML5Public2018-08-13 14:23
ReporterStewart BishopAssigned ToAlan Savage 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
PlatformHTML5OSmacOSOS Version
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0028089: HTML5: Safari won't play streaming MP3s until after the user interacts with the game
DescriptionIf you run HTML5 and your default browser is set to Safari, then you'll never get any audio with your game as we generate MP3s. If you take the URL of your HTML5 game and then open it in Chrome/Firefox, then your game will work as expected. We should look into seeing if this is a format issue or if we need to change the type of audio we output by default.
Steps To Reproduce1) Open UNDERTALE
1) Run it on HTML5 from GMS2
3) Open it in Safari
4) See that your game has an audio icon on its tab but nothing is playing
5) Copy the URL and open it in Chrome instead
6) See that your game now has audio
Tags1_4_final
1.4 Found In
2.x Runtime Found In2.1.2.161
2.x Runtime Verified In2.1.1.1

Activities

Russell Kay

2018-05-21 16:14

Manager   ~0059865

Unable to reproduce in v9.9.1.1037

Stewart Bishop

2018-06-28 11:55

Adminstrator   ~0060717

Bug still happens using the same project and same steps

Alan Savage

2018-08-07 16:06

Developer   ~0061086

issue is due to safari auto-play restrictions blocking streamed audio playback without prior user interaction
-fixed by playing silent streamed audio on first mouse event, which allows further streamed audio to play without issue; streamed audio will not play before the first mouse event

Dan

2018-08-13 14:23

Adminstrator   ~0061210

Fix is in 1.4.9999.