View Issue Details

IDProjectCategoryView StatusLast Update
0027608RunnerPhysicsPublic2018-02-07 14:49
ReporterSam CummingAssigned ToMike Dailly 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target VersionFixed in Version 
Summary0027608: Physics: Assigning to a physics variable while physics is disabled gives unclear error message
DescriptionIf you assign to a physics variable while physics is not completely set up (the object is physics enabled and the room is physics enabled), the runner will throw an exception stating:

Pop :: Execution Error - Variable set failed phy_speed_x - read only variable?

It is proposed that this error is made more readable, since it is difficult to tell the root cause (that physics is disabled).
Steps To Reproduce1. Run the attached project.
2. Observe error.
3. Enable object's physics and room's physics.
4. Observe that the error is no longer thrown.
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.1.0.136
2.x Runtime Verified In

Activities

Sam Cumming

2017-08-30 09:52

Developer  

Bug.yyz (14,471 bytes)

Mike Dailly

2017-08-30 14:56

Manager   ~0055164

fixed in github