View Issue Details

IDProjectCategoryView StatusLast Update
0027213RunnerFunctionsPublic2018-02-07 14:49
ReporterDanAssigned ToMike Dailly 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version 
Target VersionFixed in Version 
Summary0027213: Functions: draw_text_ext() doesn't work correctly if the string has multiple consecutive spaces (even crashes HTML5 tabs)
DescriptionAs you can see in the attached sample, draw_text_ext() doesn't work correctly if the string has multiple consecutive spaces.

On Windows some text is repeated and HTML5 just crashes the tab.
Steps To Reproduce1. Start GMS and import the attached sample.
2. Run it for Windows and observe the word "Freeze" is incorrectly repeated.
3. Run it for HTML5 and observe the game never starts up.

Repro: 100%
TagsNo tags attached.
1.4 Found In1.4.1772
2.x Runtime Found In
2.x Runtime Verified In

Activities

Dan

2017-07-27 14:32

Adminstrator  

drawTextExtFreeze.gmz (256,466 bytes)

Mike Dailly

2017-09-04 14:10

Manager   ~0055254

fixed in gitlab.

However.... if the size of the word over shots the width available, it will not split the word, it'll just print and overshoot. This is by design.