View Issue Details

IDProjectCategoryView StatusLast Update
0026663RunnerSpinePublic2017-07-28 14:08
ReportermesshofAssigned ToMike Rennie 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target VersionFixed in Version 
Summary0026663: skeleton_attachment_create creates attachments scaled up too large
DescriptionI'm using skeleton_attachment_create() to make an attachment from a sprite. Then in animation update I use skeleton_attachment_set to set it to a slot. It attaches ok, but it's way too big. If I set the x and y scale in skeleton_attachment_create to 0.61 it looks closer to normal, but it's still a bit stretched or something in the x axis.
Steps To ReproduceLoad up the gm example and hold space to see the attachment set to the slot as close as I could get it.
Additional InformationUsing Spine runtime v3.6.16
1.4 Found In7.7.1466
2.x Runtime Found In2.0.6.93
2.x Runtime Verified In

Activities

messhof

2017-05-26 06:20

Updater  

spine_attachment_bug.zip (2,912,831 bytes)

Mike Rennie

2017-05-26 11:52

Developer   ~0053366

This was caused by attachments not handling cropped images properly - this has now been fixed.

Sam Cumming

2017-07-28 14:08

Adminstrator   ~0054671

Verified > 7.7.1543 - Closing.