View Issue Details

IDProjectCategoryView StatusLast Update
0026251RunnerFunctionsPublic2017-08-04 14:04
ReporterStewart BishopAssigned ToMike Dailly 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target VersionFixed in Version 
Summary0026251: Functions: sprite_replace does not work on HTML5
DescriptionSample project replaces a sprite from sprite1 to sprite2.

TESTED AND WORKING ON: windows, android, uwp
NOT WORKING: html5
Steps To Reproduce1) Run sample project on Windows to see expected output
2) Run project on HTML5
3) See that where it should have replaced the sprite it removed the sprite
1.4 Found In1.99.533
2.x Runtime Found In2.0.6.68
2.x Runtime Verified In9.9.1.668

Activities

Stewart Bishop

2017-04-19 14:45

Adminstrator  

spritereplacebug.gmz (269,523 bytes)
spritereplacebuggms2.yyz (46,503 bytes)

Mike Dailly

2017-04-21 10:18

Manager   ~0052856

Last edited: 2017-04-21 10:52

View 2 revisions

Not a bug. It helps when you specify it actually HAS a frame to load.

example has:
sprite_replace(spr,working_directory+"sprite2.png",0,0,0,0,0)

should be:
sprite_replace(spr,working_directory+"sprite2.png",1,0,0,0,0)


http://docs2.yoyogames.com/index.html?page=source%2F_build%2F3_scripting%2F4_gml_reference%2Fsprites%2Fsprite_replace.html


if anything, "native" should fail to load this. Changing to 1 (as it should be), it works fine.
EDIT: Will change HTML5 to accept "0" as meaning a 1 - same as windows, just for consistency sake.