View Issue Details

IDProjectCategoryView StatusLast Update
0025821RunnerSpinePublic2018-02-05 16:28
ReporterzenAssigned ToMike Rennie 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform OS OS Version
Product Version 
Target VersionFixed in Version 
Summary0025821: Spine: worldAngle from Spine animation [ds map] gives the value "<undefined>"
DescriptionUsing the following function call on a valid Spine will give the value "<undefined>":

ds_map_find_value(map, "worldAngle");

Debugging the code will show that the value worldAngle is not present in the map that is created by skeleton_bone_state_get
Steps To ReproduceRun the attached .gmz with Target Windows
Notice that you receive an error
Notice that the cause of the error is ds_map_find_value(map, "worldAngle"); returning "<undefined>"
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/119982
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In
2.x Runtime Verified In

Activities

Dan

2017-07-25 16:58

Adminstrator   ~0054555

Last edited: 2017-07-25 17:02

View 3 revisions

This value was removed in the Spine 3.4 update, so it is no longer valid now. Anyone who called this will need to update their code.

http://esotericsoftware.com/forum/spBone-worldRotation-renamed-or-replaced-5937

"appliedAngle" appears to be the newer version and is already in EA551/1.4.1767, however there is also worldAngleX and worldAngleY, which we will now expose in the map for 1.4.1770+.