View Issue Details

IDProjectCategoryView StatusLast Update
0025751Runner[All Projects] HTML5Public2017-03-17 11:30
ReporterYellowAfterlifeAssigned ToFritz 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 8OS Version8.1
Summary0025751: HTML5: GetWithArray should return [] instead of null on no matching type
DescriptionCurrently GetWithArray returns null if all other options (== all, is object id, is instance id) fail, meaning that doing var q = noone; place_meeting(x, y, q), for example, will throw exceptions from inside place_meeting on attempt to get null' length.

with-loops are unaffected because they use for (key in obj) loops, which just do nothing when asked to iterate over a null.
1.4 Found In7.7.1398
2.x Runtime Found In
2.x Runtime Verified In

Activities

YellowAfterlife

2017-02-22 02:04

Developer  

a_bug.gmz (119,086 bytes)

Fritz

2017-02-27 16:42

Developer   ~0051762

42713685a9374cb94e2f471d1e47456edff43b3a

Ross Manthorp

2017-03-17 11:30

Adminstrator   ~0052286

Verified. Closing.