View Issue Details

IDProjectCategoryView StatusLast Update
0025619Runner[All Projects] MacPublic2017-03-17 11:10
ReporterzenAssigned ToFritz 
PriorityHighSeverityA - Crash/HangReproducibility<25%
Status ClosedResolutionFixed 
PlatformmacOSOSSierraOS Version
Product Version 
Target VersionFixed in Version 
Summary0025619: Mac OSX: "NULL cString" crash on game start-up for some Sierra users
DescriptionHello, one of my customers has reported a bug on macOS Sierra that appears to be identical to the bug reported in this thread:

https://forum.yoyogames.com/index.php?threads/mac-osx-sierra-not-working.9491/

I'm afraid I cannot reproduce it on my own Mac Mini, which is also running Sierra. But from the looks of the error, it seems to be a problem with Game Maker Studio rather than my own code.

(If I'm wrong, I'd appreciate if you could give me an idea of some changes I could make to fix this.) SAMPLE URL:
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/118365
1.4 Found In1-4-1763
2.x Runtime Found In
2.x Runtime Verified In

Activities

Fritz

2017-02-14 15:24

Developer   ~0051575

I've fixed the crash which was occuring when attempting to display an error dialog before the window caption was set. This will at least allow the error to be readable.