View Issue Details

IDProjectCategoryView StatusLast Update
0025616Runner[All Projects] FunctionsPublic2017-03-17 11:12
ReporterzenAssigned ToFritz 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform OS OS Version
Summary0025616: Functions: Using path_start() with negative speed and path_action_stop, causes the object to jump to to end of path
Descriptionusing this:
path_start(some_path, -10, path_action_stop, true)

the instance jumps to the end of the path (path_position = 1)
as expected (because absolute = true), moves along the path
in reverse, however, when it reaches start of path
(path_position = 0), it jumps to the end of the path immediately

I think the intended behaviour of "path_action_stop" is for the
instance to stop when reaching the endpoints of the path,
whether it is the start or the end, depending maybe on the
sign of "path_speed"
Steps To ReproduceOpen the attached .gmz
Run with target Windows
Note absolute = true
Press <Enter> to go in reverse (negative path_speed)
Notice how the instance jumps to the end when reaching the start of path
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/118110
1.4 Found In1-4-1763
2.x Runtime Found In
2.x Runtime Verified In

Activities

Kevin Brown

2017-02-10 12:30

Manager  

path_start_test.gmz (10,735 bytes)

Fritz

2017-02-15 16:24

Developer   ~0051593

(NB not "fixing" other part of this as it is undefined what playing a path relative with a negative speed is going to mean & changing may break other peoples projects)(after discussion with MD).