View Issue Details

IDProjectCategoryView StatusLast Update
00250461.4 IDE BugsSavingPublic2018-02-05 16:28
ReporterYellowAfterlifeAssigned ToFritz 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformOSWindows 8OS Version8.1
Summary0025046: Saving: IDE fails to load projects if you say "no" to saving the previous project
DescriptionThis seemed to have started happening somewhat recently in red builds,
Steps To Reproduce1. Open the attached project.
2. Open Scripts - gmcallback_test.
3. Add a linebreak to the script code.
4. Press "Save" on toolbar to save the project.
5. Pick File - Recent projects - (any other project)
6. Press "No" on "Save changes?" dialog.
7. Observe the IDE ignoring the order to load other project.
Additional InformationUnder some circumstances this also prevents the project from being reloaded correctly, which now a few times had resulted in loosing some time to debugging what would turn out to be external changes being discarded in favor of previous IDE edit.
1.4 Found In7.7.1380

Relationships

duplicate of 0024769 ClosedFritz General: Importing a gmz whilst already working on another project doesn't work if you choose to not save your current project 

Activities

YellowAfterlife

2016-12-26 08:57

Developer  

a_bug.gmz (119,083 bytes)

Fritz

2017-03-21 15:22

Developer   ~0052393

607bb427e29ad20e98ebfa6aa8080fcf08107bb2