View Issue Details

IDProjectCategoryView StatusLast Update
0024967Runner[All Projects] HTML5Public2017-08-02 16:34
Reporterdralon@yahoo.comAssigned ToMike Dailly 
PriorityNoneSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform OS OS Version
Product Version 
Target VersionFixed in Version 
Summary0024967: HTML5: json_encode() behaves differently on Windows and HTML5
DescriptionIn windows:
json_encode() will store an array inside a ds_map in a format that looks like an array. json_decode() will interpret these as lists.

Sample Windows json_encode(ds_map_of_array) output:
"100003": [ 768.000000, 576.000000, 0.000000, 0.000000 ]

In HTML5:
json_encode() will store arrays inside of a ds_map in a csv string. json_decode() does not generate a list from this.

Sample HTML5 json_encode(ds_map_of_array) output:
"1000001":"768,576,0,0" SAMPLE URL:
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/114198
1.4 Found In1-4-1760
2.x Runtime Found In
2.x Runtime Verified In

Activities

Kevin Brown

2016-12-16 14:40

Manager  

json_encode.gmz (221,540 bytes)

Mike Dailly

2017-06-12 22:21

Manager   ~0053562

fixed