View Issue Details

IDProjectCategoryView StatusLast Update
0024068Runner[All Projects] HTML5Public2017-03-17 11:16
ReporterYellowAfterlifeAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 8OS Version8.1
Summary0024068: HTML5: ds_map_find_value does not need to display warnings for nonexistent keys
DescriptionOriginal behaviour (displaying "Error: Key (key) not found in ds_map[ind]") was established at the time when GameMaker: Studio did not yet have an `undefined` type, therefore was needed to avoid silent failure with returning 0. Since introduction of `undefined` values, this is no longer needed, and it should silently return `undefined` as other targets do.
1.4 Found In7.7.1305
2.x Runtime Found In
2.x Runtime Verified In

Activities

YellowAfterlife

2016-10-08 17:40

Developer  

a_bug.gmz (119,437 bytes)

Russell Kay

2017-02-21 10:29

Manager   ~0051698

Fixed in gitlab - 07fb619 - no longer complains and returns undefined

Ross Manthorp

2017-03-17 11:16

Adminstrator   ~0052274

Verified. Closing.