View Issue Details

IDProjectCategoryView StatusLast Update
0023720Runner[All Projects] Windows (YYC)Public2017-03-01 16:19
ReporterzenAssigned ToRussell Kay 
PriorityNoneSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindows (YYC)OS OS Version
Product Version 
Target VersionFixed in Version 
Summary0023720: Win(YYC): Reading variable produces different results with YoYo Compiler for Windows
DescriptionScript produces different results depending on whether a variable is outputed with show_debug_message() or not.

The result is deterministic with the provided project (which is the complete Game Maker project). Not sure how to reproduce with a new project from scratch.

The script in question is called scr_set_scale_fx_y.

Essentially changing the script in the following ways:

 show_debug_message("argument1.y : "+string(argument1.y));
show_debug_message("argument1.image_xscle : "+string(argument1.image_xscale));
show_debug_message("argument1.image_yscle : "+string(argument1.image_yscale));

VS

show_debug_message("argument1.y : "+string(oldY));
show_debug_message("argument1.image_xscle : "+string(oldScaleX));
show_debug_message("argument1.image_yscle : "+string(oldScaleY));

Changes the output from:

xscale : 0.47
yscale : 0.47

VS

xscale : 0.65
yscale : 0.65

I also tested briefly with BETA version V 1.99.493 of Game Maker Studio and the problem was still happening.

If I had a dumb guess as to why this is happening, I'd say reading the variable from argument1.XXXXX refreshes some kind of cache and that fixes the issue, while not reading it keeps the cache in a faulty state? Maybe?
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/110263
1.4 Found In1.4.1760
2.x Runtime Found In
2.x Runtime Verified In

Activities

Russell Kay

2016-11-28 18:19

Manager   ~0050516

Fixed on gitlab - 8f80613

Ross Manthorp

2017-03-01 16:19

Adminstrator   ~0051877

Fixed. Closing.