View Issue Details

IDProjectCategoryView StatusLast Update
0023293RunnerNetworkingPublic2018-05-09 16:32
ReporterJDBarAssigned ToYellowAfterlife 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOS OS Version
Product Version 
Target VersionFixed in Version 
Summary0023293: Networking: Evidence of network_send_udp() causing memory leak
DescriptionUpon sending data with network_send_udp(), memory usage will increase by about 0.03KB every time. Here is a recording of the debug memory graph when a packet is sent every step at a room_speed of 500: http://i.imgur.com/Jw05X7a.gifv

I have attached a GMZ file with a project that includes the following:

obj_test:
Create Event:
/// Create Server and Buffer
server = network_create_server(network_socket_udp, 58008, 32);
buffer = buffer_create(1, buffer_grow, 1);

Step Event:
/// Write and send buffer every step.
buffer_seek(buffer, buffer_seek_start, 0);
buffer_write(buffer, buffer_bool, true);
network_send_udp(server, "127.0.0.1", 58008, buffer, 1);
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/110007
TagsNo tags attached.
1.4 Found In1.99.503
2.x Runtime Found In
2.x Runtime Verified In

Activities

Stewart Bishop

2016-08-23 10:17

Adminstrator  

UDP Memory Leak Test.gmz (8,538 bytes)

YellowAfterlife

2018-02-20 13:16

Developer   ~0057808

Fixed in gitlab - this was a Windows-exclusive and UDP-exclusive issue due to select system functions requiring helper structures to be freed in a specific way.

Sam Cumming

2018-03-02 11:08

Developer   ~0057952

Verified > 1.4.1798 - Closing.