View Issue Details

IDProjectCategoryView StatusLast Update
0023281Runner[All Projects] ExtensionsPublic2017-07-10 14:54
ReporterMaxyAssigned ToRussell Kay 
PriorityNoneSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOS OS Version
Product Version 
Target VersionFixed in Version 
Summary0023281: Extensions: Problem with passing more than 4 arguments in extensions
DescriptionIn the EA Version 1.99.493 and EA Version 1.99.475 There is a problem with passing arguments.

I checked this with extension containing a DLL and with Windows export only (both VM and YYC). If needed, I can check it with Android extension too.

First, when a given extension's function uses more than 4 arguments, the function stops working. (it does not pass any arguments. You can even put a string as one when it expect a double, and it will compile and run. Of course the function will not work).

Similar, using external_define with more than 4 argtype, will produce error on game's startup. Using less, will make it work.

My guess is, it is caused by "Changed to fully remove the 16 arguments per function limitation" change in EA Version 1.99.475, as it all works fine in Version 1.4.1757.
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/109665
1.4 Found In1.99.503
2.x Runtime Found In
2.x Runtime Verified In

Relationships

has duplicate 0027031 ClosedSteven Campbell 2.0 IDE Bugs Compiling: [IDE should check DLL arguments pre-compilation and error if not the correct type] 

Activities

HolgEntertain

2016-11-14 19:45

Reporter  

DllTest.gmz (23,277 bytes)
dll problem.png (69,003 bytes)
dll problem.png (69,003 bytes)

HolgEntertain

2016-11-14 19:46

Reporter   ~0050264

This bug is now on the main branch as well. GMS 1.4.1763
Attaching example project. Dll code copied to a comment in project file

Russell Kay

2016-11-23 21:12

Manager   ~0050431

Fixed in gitlab - 2596403