View Issue Details

IDProjectCategoryView StatusLast Update
0020135Marketplace Assets/Extensions[All Projects] ExtensionsPublic2017-03-01 11:33
ReporterbatblasterAssigned ToFritz 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformiOSOSiOSOS Version
Summary0020135: Extensions: Google Play Services doesn't pause the game when an advert is running
DescriptionIf you run an app in Android or Windows mode and for example you show an interstitial advert the os_is_paused is called automatically.

In iOS if you press the home button the app goes in pause but if you show and advert the app not seem to goes in pause.
Steps To ReproduceOpen a new project
Add the Google play Services Extension to your project
Create an object with a step event and count the frames
Show an advert as video or interstitial and you can see the app in background is not paused
When you close the advert the value of the step counter is much more.

Activities

kyzcreig

2016-02-01 10:49

Reporter   ~0041682

I think this may be an issue with the heyzap SDK or extension but I could be wrong. Not saying it's not something GMS should take care of, but the extension author would know better what needs to be addressed.

What I do is run a pause object when the an advert is shown. And then use this "ad_is_hidden" callback to unpause.

Stewart Bishop

2016-02-04 14:36

Adminstrator   ~0041723

I've assigned this on as the Google Play Services extension is one of our extensions so that's on us to fix if the game is not pausing correctly.

However for HeyZap SDK/Extension that would be on the original author to fix as this is something the author has to add to their extension.

Daniel Cleaton

2016-10-04 11:16

Adminstrator   ~0049395

Last edited: 2016-10-04 11:18

View 2 revisions

We now set os_is_paused when window not visible due to interstitial, etc. EA509+