View Issue Details

IDProjectCategoryView StatusLast Update
00200531.4 IDE BugsRoom EditorPublic2018-02-05 16:28
ReporterMikkel ToxweniusAssigned ToFritz 
PriorityVery HighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform OS OS Version
Summary0020053: Room Editor: Copying an instance of an object that has been renamed pastes the instance as an invisible and very small object
DescriptionCopy-Pasting an object instance sometimes pastes the instance as an invisible and infinitely small object.

It's like the object is there, but it is not (I can select it from the instance order list and it shows the select outline box where the object is in the room, but the object is not actually displayed and the select box is at what seems to be it's minimum size.)

When it happens to an instance it seems to always happen for that particular instance in that room. However deleting the instance and creating another instance from same object seems to fix the issue for that new created instance.

I also uploaded this video that shows what happens: https://www.youtube.com/watch?v=ZrjOMiE178M&feature=youtu.be SAMPLE URL:
Steps To Reproduce1. Create a sprite.
2. Create an object.
3. Assign sprite to object.
4. Place object in room.
5. Rename object.
6. Copy/paste object, the bug will happen. (Interestingly enough, when you look in the instance order window, the name of the copied object is still the old object name, before the renaming.)
7. Deleting the object from the room and placing the object anew will make it able to be copy-pasted without problems (and object name matches in instance order list).
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/98960
1.4 Found In1.4.1690

Activities

Fritz

2017-03-22 14:18

Developer   ~0052410

be223de51a9f80337992aafb7ec5c24eac742244