View Issue Details

IDProjectCategoryView StatusLast Update
0019862Runner[All Projects] Amazon FirePublic2018-05-10 14:08
ReporterDanAssigned ToFritz 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ResolvedResolutionUnable To Reproduce 
PlatformAmazon FireOSAndroid (Amazon)OS Version
Product Version 
Target VersionFixed in Version 
Summary0019862: Amazon Fire: App crashes when selecting settings button for runner web server connection
DescriptionIf you deploy a run version of your game and subsequently try to launch it again from the Amazon Fire you will see that this fails to find the data file and looks for a web server back on the PC. If you click the button to edit your connection details this will crash/close the app.

Expected: Either all of the data is sent over and the web server connection is never seen, or this dialogue should work properly.
Steps To Reproduce1. Ensure you have Amazon on your license.
2. Start Studio and load/create any project.
3. Run the project for Amazon Fire.
4. Close the app on the Fire device.
5. Use the application manager on the Fire TV to launch the app again.
6. Observe this will sit on an incorrect details screen.
7. Try selecting the button to edit the connection details and observe the app silently disappears.

Repro: 100%
Additional InformationThis was found on a Fire TV - tablets not checked yet.
TagsNo tags attached.
1.4 Found In1.4.1683
2.x Runtime Found In
2.x Runtime Verified In

Activities

Dan

2016-01-14 14:04

Adminstrator   ~0041537

Note that while this report was made for Amazon, the dialogue and runner are generic across all Android devices, so many devices can reproduce the same.

Dan

2016-01-18 15:56

Adminstrator   ~0041580

I still get this issue in 1702, so Reopening.

Russell Kay

2018-05-10 14:08

Manager   ~0059508

Unable to reproduce in GMS2