View Issue Details

IDProjectCategoryView StatusLast Update
0016938DebuggerWatchesPublic2018-02-05 16:28
ReporterkabecaoAssigned ToFritz 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Summary0016938: Watches: Arguments are always 0 in the watcher
DescriptionYou can see temporary variable of the script in the watcher but argument0...15, argument[index] and argument in the name field always return 0.

Activities

Neil Wicker

2015-01-23 10:30

Updater   ~0035349

You can currently see the values in the call stack window, but I'll assign this on to be added to the watcher window as well, as that should be possible. They could also appear in the locals/build in vars window but that may be more difficult to implement.

Andrew Hodgins

2016-08-30 05:46

Reporter   ~0047465

I've stumbled across this issue as well. I wasn't sure if it was my own fault or a bug but I noticed it hadn't come up in release notes. I would just like to nudge this issue back into attention if possible, seeing as it's been a year and a bit since any updates were made. That's me being a pedant and a pissant for the day.

Fritz

2017-03-20 10:56

Developer   ~0052350

Arguments have been added to the locals window in the debugger