View Issue Details

IDProjectCategoryView StatusLast Update
0011617Runner[All Projects] BackgroundsPublic2017-03-01 11:33
ReporterFraser TomisonAssigned ToMike Rennie 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 7OS Version
Product Version 
Target VersionFixed in Version 
Summary0011617: Background: When a large background is scaled down to fit a texture page, it is not always scaled back up
DescriptionSpecifically: If you use background_duplicate on a large background resource, the resulting background will report its dimensions that the same of the background resource it was copied from, however it will contain only the scaled down image.

Meaning, if you 'stretch' this background to fit the entire room, it will only take up a fraction of the room.

Also, if you use background_draw_general() on any background resource that has been scaled down by GM, it will draw the background as the scaled down version. However, it will properly scale the image back up when you use draw_part() or draw_ext().
Steps To Reproducecreate new background resource, make width > 1024
set it as a room background, then in code duplicate it, and assign the duplicate as the new background.

You should be able to notice the new background is half the size.

Similar process with draw_general().
Additional InformationIncluded gmtest gmz showcasing the issue. Read output log to see what should be expected in screenshots.

Notice that duplicate and draw_general are not working as intended?
1.4 Found In7.7.35
2.x Runtime Found In
2.x Runtime Verified In

Activities

Fraser Tomison

2013-07-25 14:37

Updater  

gmtest-BackgroundScaling.gmz (7,159,430 bytes)