Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002894GameMaker: Studio[All Projects] Functionspublic2012-04-23 16:262013-03-05 15:02
Reportergarpgames 
Assigned ToRussell Kay 
PriorityMediumSeverityC - GeneralReproducibility100%
StatusclosedResolutionwon't fix 
PlatformDell XPS 15ZOSWindowsOS Version7
Summary0002894: Random function doesnt give random results
DescriptionWas playing with some code for learning purposes and noticed that the random function in the init level script wasn't properly working in Gamemaker Studio. It worked fine in Gamemaker 8.1. You should get different blocks at the start of the room, but in Studio you allways get the same blocks????


  
Steps To ReproduceUse the file I uploaded and run the game..
Additional Informationnoop
GM Version
Attached Files? file icon demo_bug.gmz [^] (245,279 bytes) 2012-04-23 16:26

- Relationships

-  Notes
(0001294)
Russell Kay (administrator)
2012-04-23 16:30

This is by design - if you want things to be truly random then call randomize() at the start of your code...

But I would caution you against this as it is very tricky to track down bugs caused by random() as each time the code is run it is not deterministic...

- Issue History
Date Modified Username Field Change
2012-04-23 16:26 garpgames New Issue
2012-04-23 16:26 garpgames File Added: demo_bug.gmz
2012-04-23 16:30 Russell Kay Note Added: 0001294
2012-04-23 16:30 Russell Kay Status new => resolved
2012-04-23 16:30 Russell Kay Resolution open => won't fix
2012-04-23 16:30 Russell Kay Assigned To => Russell Kay
2013-03-05 15:02 Ross Manthorp Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker