Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002869GameMaker: Studio[All Projects] Physicspublic2012-04-22 00:182013-03-05 15:06
Reportersophiebelle 
Assigned ToChris Harrison 
PriorityLowSeverityWishReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Summary0002869: Implement kinematic physics
DescriptionIt would be nice to set some physics objects to affect other objects but not be affected themselves. This is achieved to some degree by setting the density to ∞ (0), but then no motion of any sort can be applied to the object.
Additional InformationBox2D has the static, kinematic and dynamic classes. All of the objects in GM:S appear to be dynamic, with the ability to force static by setting density to ∞, but no support for the kinematic type has been introduced so far. Things like gates, pinwheels and moving platforms would benefit from being kinematic (not adjusting their motion when something else collides with them).
GM Version
Attached Files

- Relationships

-  Notes
(0001372)
Chris Harrison (developer)
2012-04-25 17:37

>= v1.0.147

(The following is only true for the next release)

If you set the physics velocity (via phy_speed_x/phy_speed_y) of the instance to non-zero and the instance is a static body it will make it into a kinematic body automatically, but since it isn't recommended that you change the nature of the body on the fly there is a routine 'physics_fixture_set_kinematic(fixture)' which lets the physics simulation know your intention to have the instance move.

- Issue History
Date Modified Username Field Change
2012-04-22 00:18 sophiebelle New Issue
2012-04-22 18:12 Mike Dailly Assigned To => Chris Harrison
2012-04-22 18:12 Mike Dailly Status new => assigned
2012-04-25 17:37 Chris Harrison Note Added: 0001372
2012-04-25 17:37 Chris Harrison Status assigned => resolved
2012-04-25 17:37 Chris Harrison Resolution open => fixed
2013-03-05 15:06 Ross Manthorp Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker