Mantis

View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
00277342.1 IDE Bugs [2.x IDE Bugs] Build UWPPublic2017-09-08 11:262017-10-18 15:15
ReporterDaniel Cleaton 
Assigned ToRussell Kay 
PriorityVery HighSeverityB - MajorReproducibility100%
StatusClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Summary0027734: Build UWP: Users reporting submission fails for unallowed functionality when submitting their games to the store
DescriptionHello, I am getting a failed certification when I submit my game to the windows store. Here is the report:

Supported API test

FAILED
Supported APIs

Error Found: The supported APIs test detected the following errors:
API getenv in api-ms-win-crt-environment-l1-1-0.dll is not supported for this application type. WinUAPRunner.exe calls this API.

Impact if not fixed: Using an API that is not part of the Windows SDK for Windows Store apps violates the Windows Store certification requirements.

How to fix: Review the error messages to identify the API that is not part of the Windows SDK for Windows Store apps. Please note, apps that are built in a debug configuration or without .NET Native enabled (where applicable) can fail this test as these environments may pull in unsupported APIs. Retest your app in a release configuration, and with .NET Native enabled if applicable.

See the link below for more information:
Alternatives to Windows APIs in Windows Store apps - http://go.microsoft.com/fwlink/?LinkID=244022 [^]
Steps To ReproduceSubmit a package to the Microsoft Store.
Additional Informationhttps://forum.yoyogames.com/index.php?threads/store-certification.32808/#post-210194 [^]
Version Found In2.1.0.212
2.x Runtime Version2.1.0.136
Version Verified In
2.x Runtime Version Verified In2.1.0.144
Attached Files

- Relationships

-  Notes
(0055464)
Russell Kay (Manager)
2017-09-13 10:30

Fixed in gitlab - not sure if it is on green
(0055491)
Daniel Cleaton (Administrator)
2017-09-14 11:07

Runtime 2.1.0.144 released a short while ago today to fix this. Have submitted a valid package to the store page for QuadBreak using this version.

Closing.
(0055497)
Daniel Cleaton (Administrator)
2017-09-14 14:44

1.4.1773 out now also with this fix.


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker