Mantis

View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0026329RunnerWindows (YYC)Public2017-04-27 16:372017-08-03 17:10
ReporterStewart Bishop 
Assigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility<25%
StatusClosedResolutionFixed 
PlatformOSOS Version
Summary0026329: Windows (YYC): Using numbers larger than a 32 bit unsigned number causes issues
DescriptionRunning with normal "Windows" as a target worked fine, but when I switched to "Windows YYC" I got this error in the compile window: http://pastebin.com/01LSSL2f [^]

It appeared to be because I was using modulo with $100000000 which is 1 more than what a 32 bit unsigned number can hold. When I removed one of the zeros things worked fine, windows YYC worked just like the normal windows target. In the beginning I had this error appearing 3 times in the compile window. I removed 1 zero from all the places where I had $100000000 written (which was more than 3 places), and all errors disappeared.

I tried to reproduce it in a separate project (because my main project is quite large). I didn't manage to reproduce the compile window error, but I managed to get different results between the normal windows target and the windows YYC target. If you import the gmz linked to in this bug report, YYC will print 0 whenever you press a key, while normal windows will print an expected random value. Removing one of the zeros from $100000000 makes windows YYC and normal windows act in the same way, both returning random numbers.
Steps To Reproduce1) Run project in VM
2) Press any key
3) See that you get a random number
4) Run project in YYC
5) Press any key
6) See that you get 0
1.4 Version1.99.533
2.x Runtime Version
2.x Runtime Version Verified In
Attached Files? file icon Bug report YYC problems with large integer numbers.gmz [^] (9,087 bytes) 2017-04-27 16:37

- Relationships

-  Notes
(0052972)
Russell Kay (Manager)
2017-05-02 09:53

Fixed in gitlab - header file fix it was erroneously assuming that the rhs was a real as well, needed to call REAL_RValue


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker