Mantis

View Issue Details Jump to Notes ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0016588GameMaker Runner[All Projects] FunctionsPublic2014-10-28 14:492016-10-07 10:05
ReporterDaniel Johnston 
Assigned ToFritz 
PriorityHighSeverityB - MajorReproducibility100%
StatusClosedResolutionFixed 
PlatformiOSOSiOSOS Version8
Summary0016588: Functions: Push notifications don't fire in iOS 8
DescriptionAs of iOS 8 the function push_local_notification(fire_time, title, message, data); no longer fires a notification on the device.

It seems from some of the submitted logs from users that apple have changed the way notifications are set.

Edit: Appears that it may apply to remote notifications too, would need a live sample to confirm.
Additional InformationGMC: http://gmc.yoyogames.com/index.php?showtopic=642090 [^]
Helpdesk:

https://yoyogames.zendesk.com/agent/tickets/74699 [^]
https://yoyogames.zendesk.com/agent/tickets/74804 [^]
https://yoyogames.zendesk.com/agent/tickets/74467 [^]
GM Version1.99.264
Attached Files? file icon PushNotes_264.gmz [^] (955,296 bytes) 2014-10-28 14:49

- Relationships

-  Notes
(0034292)
Daniel Cleaton (Administrator)
2014-11-20 15:52

"Edit: Appears that it may apply to remote notifications too, would need a live sample to confirm."

That would be up to end users to do - we don't really handle remote notifications, as that requires a custom web server or third-party mailing/notification service.
(0034428)
startoz (Reporter)
2014-11-27 10:20

It applies to remote notifications too because the app is not registering itself to get permission to send notifications, so that's a Game Maker bug.
(0049247)
Fritz (Developer)
2016-09-28 15:18

Fixed GMS to correctly request push notification entitlement when requested.

The included .gmz needs push notifications enabling in GGS->Extras, then it will work with updated GMS
(0049489)
Daniel Cleaton (Administrator)
2016-10-07 10:05

Verified fixed in 1763. Closing.


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker