Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003720GameMaker: Studio[All Projects] Physicspublic2012-05-23 16:082014-02-27 10:37
ReporterMark Alexander 
Assigned ToChris Harrison 
PriorityLowSeveritySuggestionReproducibilityN/A
StatusclosedResolutionfixed 
PlatformAllOSOS Version
Summary0003720: Suggestion: Physics: Extra variables for physics
DescriptionIf it is possible, it would be nice to have the following variables available in the physics :

phy_density
phy_friction
phy_angular_damping
phy_linear_damping
phy_restitution

That way people can change certain fixture properties "on the fly" rather than having to recreate the instance and the fixture.
GM Version
Attached Files

- Relationships

-  Notes
(0002633)
alexandervrs (updater)
2012-05-23 23:07

I think you mean phy_angular_damping than phy_rotational_damping.
But yeah, these are my wish as well.
(0005008)
Mark Alexander (developer)
2012-07-04 11:09

Yes, angular... Changed the bug to suit... As for the image that has been added, this is not relevant to the problem at hand, but rather bug 3699, so I have removed it from this post.
(0020118)
cloudbomb (reporter)
2013-04-17 18:58

I agree that this is something desperately needed for a proper efficient workflow. The current method is simply too tedious and extremely inefficient.
(0020857)
Chris Harrison (developer)
2013-05-06 10:10

I think the reason why I didn't put these in to start with is because they're defined at a fixture level and you can have multiple fixtures per body if you go via gml.
(0024121)
Chris Harrison (developer)
2013-08-30 16:36

And now that you get a fixture index back when you call physics_fixture_bind() we can have access to the friction, density and restitution.

physics_set_friction(fixture, friction)
physics_set_density(fixture, density)
physics_set_restitution(fixture, restitution)
physics_get_friction(fixture)
physics_get_density(fixture)
physics_get_restitution(fixture)

NB: The fixture referred to is the one you get back from physics_fixture_bind() NOT the one from physics_fixture_create().
(0024129)
Chris Harrison (developer)
2013-08-30 17:37

See note about density, friction and restitution.

phy_linear_damping and phy_angular_damping as well as phy_speed (which you can't set).

v >= 1.2.1131

- Issue History
Date Modified Username Field Change
2012-05-23 16:08 Mark Alexander New Issue
2012-05-23 16:08 Mark Alexander Status new => assigned
2012-05-23 16:08 Mark Alexander Assigned To => Chris Harrison
2012-05-23 23:07 alexandervrs Note Added: 0002633
2012-07-03 19:57 adscott1982 File Added: illustration.png
2012-07-04 11:07 Mark Alexander Description Updated View Revisions
2012-07-04 11:09 Mark Alexander Note Added: 0005008
2012-07-04 11:09 Mark Alexander File Deleted: illustration.png
2012-11-19 15:53 Daniel Cleaton Assigned To Chris Harrison => user11992
2013-01-05 20:03 Daniel Cleaton Reproducibility <25% => N/A
2013-01-05 20:03 Daniel Cleaton Platform => All
2013-01-05 20:03 Daniel Cleaton Summary Extra variables for physics => Suggestion: Physics: Extra variables for physics
2013-04-09 17:17 anonymous Note Added: 0019671
2013-04-09 21:06 Mark Alexander Note View State: 0019671: private
2013-04-15 13:45 anonymous Note Added: 0019999
2013-04-15 14:15 Mark Alexander Note View State: 0019999: private
2013-04-15 14:22 anonymous Note Deleted: 0019671
2013-04-15 14:22 anonymous Note Deleted: 0019999
2013-04-17 18:58 cloudbomb Note Added: 0020118
2013-05-03 16:50 Chris Harrison Assigned To user11992 => Chris Harrison
2013-05-06 10:10 Chris Harrison Note Added: 0020857
2013-08-30 16:36 Chris Harrison Note Added: 0024121
2013-08-30 17:37 Chris Harrison Note Added: 0024129
2013-08-30 17:37 Chris Harrison Status assigned => resolved
2013-08-30 17:37 Chris Harrison Resolution open => fixed
2014-02-27 10:37 Daniel Cleaton Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker