View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003111Studio Archive[All Projects] VariablesPublic2012-05-02 13:302015-07-07 16:49
ReporterErik Leppen 
Assigned ToChris Harrison 
PriorityMediumSeverityB - MajorReproducibility100%
StatusClosedResolutionNo Change Required 
PlatformOSOS Version
Summary0003111: No error when array index out of bounds (Windows runner)
DescriptionIf a[5] is defined, and I try to read a[6], I get no error, it simply reads as zero.
Additional InformationFor some reason the game crashes when I want to close it with Escape. Maybe this has something to do with it.
GM Version
Attached Files? file icon Test33_arrays.gmz (Attachment missing)

- Relationships

-  Notes
Chris Harrison (Developer)
2012-05-03 14:08

It's because it's not actually out of bounds, it's just not been initialised and thus you get a default value of 0 returned. It's a slight change of approach from GM8.1.

- Issue History
Date Modified Username Field Change
2012-05-02 13:30 Erik Leppen New Issue
2012-05-02 13:30 Erik Leppen File Added: Test33_arrays.gmz
2012-05-02 16:32 Chris Harrison Assigned To => Chris Harrison
2012-05-02 16:32 Chris Harrison Status New => Assigned
2012-05-03 14:08 Chris Harrison Note Added: 0001615
2012-05-03 14:08 Chris Harrison Status Assigned => Resolved
2012-05-03 14:08 Chris Harrison Resolution Open => No Change Required
2013-03-05 15:33 Ross Manthorp Status Resolved => Closed
2015-07-07 16:49 Daniel Cleaton Project GameMaker: Studio => Studio Archive

Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker